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Introduction  : This document explains the steps for setting up Data Bus Analyzer (DBA) GUI tool to
simulate or monitor ARINC 429 traffic.

Procedure
1) Software to be installed
1 | DD-4299250 | AceXtreme ARINC 429 <CDROM>\src\_Storage\dbi\software\ARINC\dd-
SDK 4299250 _4_3_2.zip

2 | DD-42999S0 | Commercial Avionics Suite | <CDROM>\src\_Storage\dbi\software\ARINC\dd-

Data Bus Analyzer NOTE3 42999S0_6_3_1.zip

Note:

)

Latest versions of these software can be downloaded from DDC’s website also.

Commercial Avionics Suite Data Bus Analyzer (DD-42999S50) is provided as a 60-day evaluation
software following which a suitable license key or dongle is needed to continue using this
software.

Ensure to restart the computer after installation of the SDK and the DBA, especially the DBA,
even if not prompted to do so. Without a restart DBA does not work.

Steps for ARINC 429 USB card Setup and Configuration
Ensure all Anti-Virus software is disabled. Login as administrator and install the SDK followed by
the Commercial Avionics Suite Data Bus Analyzer.
Connect the USB card to the computer. The card should get detected and an entry should
appear in Windows Device Manager.
Run DDC Card Manager. On the LHS, click on “ARINC 429 Devices”. Click on the entry in the grid

and change “Device Number” to 1.
M8 DDC Card Manager - Version 4.3.3.1 *

ARINC 429 Devices ‘

MIL-5TD-1553

Devices Device Name Model | Device Location Device Type
) BU-67103U2 2 Dev: 0 UsB

Description: BU-67102U/BU-67103U USB AceXtreme MIL-5TD-1553/ARINC 429
J Device

Device Type: UsE

Driver File: C:\Windows\system32\DRIVERS \acexush. sys

Driver Version: L4224

Firmware Version: 9.9

Rec Fw. Version: g
Device Number:

Device Features Update Fimware Update Driver

Manager

Auto-Assign Rescan Options 1
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)
a.

Steps for Starting Data Bus Analyzer Software and Configuring Channels

Run the DBA software as an administrator by choosing Start Menu ->“Data Device Corporation”

group->“Data Bus Analyzer”, right-click and “Run As Administrator”. The following main Window
appears. Note: Running as administrator is required only the first time after installation.
Subsequently DBA may be launched as a normal user.

129 ARINC 429 Data Bus Analyzer

i File View Run Control Configuration Engineering Help

RN NN - N N AN e R R N

Amm > "EoeR T Documentl - Micro...

FoT

‘Data Device Corporation

" 1jpg - Paint

29 ARINC 429 Data Bus... <Re WE W 1156 PM

Create a New Configuration: Create a new project configuration by choosing menu

“Configuration ->New”. This will display a “New Configuration” window as shown in fig below.
Type a new name for the configuration file & click “Open”.

@ New Configuration

~—
. « Data Bus Analyzer » Test
Ul ye

- ' +y | | Search

‘ Organize v [ Views ~ W§ New Folder

o Name Date medified

!E Documents
Bl Desktop
il Recent Places
(8 Computer
FE Pictures
FD Music
Recently Changed
FB Searches
Public

2y

Folders A

Size

Type

Tags

File name: haltest|

+ | [Configuration Fies ".cfa)

5

l [ Cancel ]

[ Open
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Choose Card Type: Click “Configuration->Hardware Card ...”. The configuration dialog box as
shown below is displayed. Pull down the “Card Type” list box and choose “BU-67103U2[1]".

ARINC 429 Cards x

Specify the DDC 429 cards available in your system. Up to 8 cands can be used simultaneously. Make
sure their 32-bit DLLs have been installed already.

Channels Card No.  Card Type Channels
Pud 1= 5 | hone ~ -
2 il 6 |none ~ il
3 | none ~ = 7 |rone e -
4 | nong ~ - 8 |none ~ -

Channels are marked as transmitters by receivers. Card number defined here will be used in the channel
mapping.

| oK | | Cancel |

Map physical channels as transmitters or receivers: Click “Control->Channel Mapping ...".

Configure the channels as below.

Channel Mapping *
This panel maps physical channels, including receivers, transmitters, and AIQ/DIC inputs and
outputs, to logical channel numbers in the first column, which will be used anywhere else.
Logical Channel Receiver Transmitter AlDADIO Input Al0SDIO Output lad
1 Card 1, TX 1
Card 1, TX 2
3 Card 1, RX 1
4 Card 1, RX 2
5 Card 1, RX 3
[ &  Jcadl.Rx4
7
]
9
10
1
12
13
i v
| Clear Al Channel Mappings | | oK | | Cancel |

Enable and Set Speed for Receive Channels: Click “Control->Receive Channels ...” and check the
“Enable” checkbox for channels on which reception is desired. Configure speed appropriately to

match the speed of the device to which this channel is connected.
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Receive Channel Selection and Control
For the best perfformance, only select those channels you will actually use.
Channels greyed out are those undefined at "Control - Channel Mapping”.
Channel | Enabled | Speed Type | Speed Value

O]
ol

3 Low 12500

4 Low 12500

5 Low 12500

[ Low 12500
o]
ol
o]
]
O]
O]
ol
ol
]
=
O]
o]
ol
o]
]

v | Cancel

f. Enable and Set Speed for Transmit Channels: Click “Control->Transmit Channels ...” and check

the “Enable” checkbox for channels on which transmission is desired. Configure speed

appropriately.

Transmit Channel Selection and Control *
For the best performance, only select those channels you will actually use.
Channels greyed out are those undefined at "Control - Channel Mapping™.

Channel | Enabled | Speed Type | Speed Value Amplitude (e
1 Low 12500 n/a
2 Low 12500 n/a
]
[T
[T
[T
0]
[T
[T
[T
[T
0]
[T
[T
[T
[T
0]
[l
[T
[T
[T v
| Cancel | oK
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V) Ope

ration

This section describes the operation of the DBA for receiving/monitoring ARINC 429 traffic and

for transmission of ARINC 429 words/labels in FIFO and Scheduled modes.

a. ARINC 429 traffic monitoring/reception: Click “File-New” to create a receive db file. Save the
file with an appropriate name. Start reception by clicking “Run->Start Reception”. If ARINC 429
traffic is found on any of the enabled channels such traffic will be displayed chronologically on
this file as below.

', Ganesh-Rx.dbax

(=)o ==

3

L R

3

Number  Chan  Alias Eq.ID Eq.MName  Label

000
022
000
022
000
022
000
022
000
022

soI
00

00

00

00

00

Raw Data
800000
200000
800000
200000
800000
800000
800000
800000
800000
200000

2. Abs. Time
O 763.3 msec
O 766.1 msec
(o} 1.76 sec
0 1.77 sec
o 2.76 sec
o 2.77 sec
o 3.76 sec
o 3.77 sec
o 4.76 sec
o 4.77 sec

Rel. Time
763.3 msec
2.8 msec
997.4 msec
2.9 msec
996.6 msec
2.9 msec
998.4 msec
2.8 msec
996.1 msec
2.9 msec

Type

S5M
00
00
00
00
00
00
00
00
00
00

Parameter Mame

Value Unit

Inter-Word Gap ~ Worg

b. ARINC 429 traffic generation/transmission: Transmission of ARINC 429 messages can be done

inone o
a.

f two ways:

FIFO: Data words that need not be transmitted on a periodic update rate may be
transmitted via the First-In-First-Out method. Transmission will take place as fast as the
ARINC card can process the data (back-to-back transmission).
Scheduled: This transmission mode involves placing a time constraint on the word/label
to be transmitted by setting a Transmission Rate, Start, Stop and Offset time (in
milliseconds) for each word.

Following sections describe steps for transmission in FIFO and Scheduled modes

FIFO mode:

i. Create a new FIFO data file by choosing “File->New”. Save the file using an

appropriate name by choosing “File->Save” (saves as a .dba/.dbax file).

ii. Add 429 labels/words to this file by double-clicking in the blank area of the file
or choosing “Edit->Add” menu. The “Add Word” window is displayed. Choose a
Label, enter 24-bit raw data, choose values for SSM, SDI and Parity and also the
channel on which this label is to be transmitted and click “Add”. Repeat this

procedure for as many labels as you need.

|
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(% Untitled2 [S=]=]
Number Chan Alias Eq.ID Eq.Name Label SDI Raw Data 2.  Abs. Time Rel. Time  Type  SSM  Parameter Name Value Unit
Add Word )
Channel: Type: Equipment:
1 | =
Label: 24bit raw data: SSM:
001 =] [ 00 [~
SDI: Parity: Absolute time: Relative time:
101~ Don't care | ~ | 0 miliseconds |0 miliseconds
Place to add:
&ppend to the end of file i AT sedule

Bit field values {double click to change):

Name Value Unit
Tester Options
<« - " | Add ] »
0o ::qtgrzvggg; I%ta%me [TInject Word Size Emor ‘ == ‘

default 32 |i= Set Bit 33 Value to 1 [~ Cancel—| /Ik

iii. Choose menu “Control->Transmission Files ..."”. This will bring up “Transmission
Files” Window as shown below.

: File View Run | Control | Configuration Engineering Help

~

? ,,D, = | Channel Alias... t Il]

Equipment IDs...
Display »

Receive Channel...
Filters...
Trigger 4

Transmit Channel...

1)) Transmission Files... Ctri+D

Channel Mapping...

Transmission Files @

A FIFO data file and a scheduled data file can be transmitted simultaneously. The FIFO
file can be any binary file of received data, while the scheduled file contains the words
for repeated transmission with rates.

File for FIFO Transmission
CADDCACommercial Avionics Utilities v6.1.0.1\Data Bus Anal | Load...
Loop this file Interfile delay: 1000 milliseconds ‘ None |

Use "File - New" to create new file, or use "File - Open" to open it if exists. Use
options in "Edit" menu to edit the file. Save in binary before transmission starts.

File for Scheduled Transmission

| Load.. || New. H Nong H Open Now ‘

Use options in "Edit" menu to edit this file. Save it before transmission starts.

The PC will beep or even lock up if the CPU or a channel is overloaded and some data
are lost in transmission.

| 0K | | Cancel

iv. Click “Load ...” button and choose the transmission FIFO file name that you
created in step “(c)-i”. You may cause this file to be continuously transmitted by
placing a check mark on “Loop this file” and setting an “Inter-file delay”.

v. Start transmission by choosing menu “Run ->Start Transmission”
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d. Scheduled Mode:

i. Invoke the “Transmission Files” window by choosing menu “Control-
>Transmission Files ...”.

ii. Under section “File for scheduled transmission” click “New...” to created a
scheduled transmission file. A File Save dialog box appears. Save the file with an
appropriate file name (saves as a .dbt/.dbtx file). The saved file appears behind
the “Transmission Files” window.

iii. Click “OK” to close the “Transmission files” window.

iv. Add messages to the scheduled transmission file by following the steps under
(c)-ii. The one difference you will notice is that the “Transmission Schedule”
button is now enabled unlike in FIFO mode.

¥
2

Mumber Status  Chan  Alias Eq.ID Egq.Mame Label 5Dl Raw Data 3. Rate Offs
Channel: Type: Equipment:
1 1=
Woaord Transmission Schedule X SSM:
Example: oK o =
W1 has rate=1000, offset=50, start=0, stop=4000.
W2 has rate=500. offset=100. start=1500. stop=none (0). Relative time:
Then once transmision is started: | Canesl | il 4
W1 will be transmitted &t 50, 1050, 2050, 3050 and stop. H L EZ=oE

W2 wil be transmitted at 1600, 2100, 2600, 3100, 3600. ...
If the computer’s CPL is ovedoaded, some words may be ignored or not on schedule.

This word's schedule is: | Transmission Schedule... |
Rate: 1000 milliseconds Start: |0 milliseconds
Offset: |0 milliseconds Stop: milliseconds. Value 2

ftype "0" or leave it empty for no auto-stop)

If this word contains any bit field defined, the values of each bit field can be varied
during transmission. The variance style and period for all defined bit fields are

Style: | Static [=] Period: |2 times of rate.
For static style, period and secondary value of each bit field will be not be used. L
| Add | =
T e Gap - - o | ==
] (1-32,000) Bt Time [ Inject Word Size Emor ‘ = |
defalt 32 = Set Bit 33 Value to 1 [Er——

v. Click “Transmission Schedule” button to bring up the “Word Transmission
Schedule” window. Enter values for “Rate”, “Start”, “Stop” and “Offset”. “Rate”
controls the frequency at which this word is transmitted, Start decides after
how long transmission of this word starts after overall transmission has been
started, Stop decides after how long transmission of this word stops.

vi. Click OK to close the “Word Transmission Schedule” window. Again click OK to
close the “Add Word” window.

vii. Start transmission by choosing menu “Run ->Start Transmission”.

|
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